const regex = /(?<=Cartoon Car \()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Cartoon Car \\()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)', 'gmi')
const str = `Focal Point (BUGS BUNNY; bugs.bunny@looonytune.car; 888-555-1111)\\nCartoon Car (DAFFY DUCK; daffyduck@disney.com; 888-555-1112)\\nCartoon Car (243; daffyduck@disney.com; 888-555-1113)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}