package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9a-zA-Z]*_?){0,2}$`)
var str = `sdas__
sqe1123
sad123
jdfo23hb13_
jdfo23hb13_09kkjkvs_vl_
jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_
jdfo23hb13_09kkjkvs_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}