const regex = /^(?:[0-9a-zA-Z]*_?){0,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9a-zA-Z]*_?){0,2}$', 'gm')
const str = `sdas__
sqe1123
sad123
jdfo23hb13_
jdfo23hb13_09kkjkvs_vl_
jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_
jdfo23hb13_09kkjkvs_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}