// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-9a-zA-Z]*_?){0,2}$").unwrap();
let string = "sdas__
sqe1123
sad123
jdfo23hb13_
jdfo23hb13_09kkjkvs_vl_
jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_
jdfo23hb13_09kkjkvs_";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}