import re
regex = re.compile(r"^(?:[0-9a-zA-Z]*_?){0,2}$", flags=re.MULTILINE)
test_str = ("sdas__\n"
"sqe1123\n"
"sad123\n"
"jdfo23hb13_\n"
"jdfo23hb13_09kkjkvs_vl_\n"
"jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_\n"
"jdfo23hb13_09kkjkvs_")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")