import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9a-zA-Z]*_?){0,2}$";
final String string = "sdas__\n"
+ "sqe1123\n"
+ "sad123\n"
+ "jdfo23hb13_\n"
+ "jdfo23hb13_09kkjkvs_vl_\n"
+ "jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_\n"
+ "jdfo23hb13_09kkjkvs_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}