re = /^(?:[0-9a-zA-Z]*_?){0,2}$/m
str = 'sdas__
sqe1123
sad123
jdfo23hb13_
jdfo23hb13_09kkjkvs_vl_
jdfo23hb13_09kkjkvs_vl_jdfo23hb13_09kkjkvs_
jdfo23hb13_09kkjkvs_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end