# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(JPY;\s*\d{1,20})/$1.00/g;t' <<< "JPY; 7112630;"