using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(JPY;\s*\d{1,20})";
string substitution = @"$1.00";
string input = @"JPY; 7112630;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}