#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(JPY;\s*\d{1,20})"
Local $sString = "JPY; 7112630;"
Local $sSubst = "$1.00"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)