use strict;
my $str = 'JPY; 7112630;';
my $regex = qr/(JPY;\s*\d{1,20})/p;
my $subst = '$1.00';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";