$re = '/(JPY;\s*\d{1,20})/';
$str = 'JPY; 7112630;';
$subst = "$1.00";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;