package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(JPY;\s*\d{1,20})`)
var str = `JPY; 7112630;`
var substitution = "$1.00"
fmt.Println(re.ReplaceAllString(str, substitution))
}