import Foundation
let pattern = #"(JPY;\s*\d{1,20})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"JPY; 7112630;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.00"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)