// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(JPY;\s*\d{1,20})").unwrap();
let string = "JPY; 7112630;";
let substitution = "$1.00";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}