# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\s]*\d+[^\s]* ?//gm;t' <<< "(Promotion) stuff ABC 1pcs
(Trial) $200 stuff XYZ 20pcs
(Test) $1000 stuff WER 5000pcs
$1000 stuff WER 5000pcs
500pcs $1000 stuff WER 5000pcs"