const regex = /[^\s]*\d+[^\s]* ?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\s]*\\d+[^\\s]* ?', 'gm')
const str = `(Promotion) stuff ABC 1pcs
(Trial) \$200 stuff XYZ 20pcs
(Test) \$1000 stuff WER 5000pcs
\$1000 stuff WER 5000pcs
500pcs \$1000 stuff WER 5000pcs`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);