#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\s]*\d+[^\s]* ?"
Local $sString = "(Promotion) stuff ABC 1pcs" & @CRLF & _
"(Trial) $200 stuff XYZ 20pcs" & @CRLF & _
"(Test) $1000 stuff WER 5000pcs" & @CRLF & _
"$1000 stuff WER 5000pcs" & @CRLF & _
"500pcs $1000 stuff WER 5000pcs"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)