import Foundation
let pattern = #"[^\s]*\d+[^\s]* ?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(Promotion) stuff ABC 1pcs
(Trial) $200 stuff XYZ 20pcs
(Test) $1000 stuff WER 5000pcs
$1000 stuff WER 5000pcs
500pcs $1000 stuff WER 5000pcs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)