using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s]*\d+[^\s]* ?";
string substitution = @"";
string input = @"(Promotion) stuff ABC 1pcs
(Trial) $200 stuff XYZ 20pcs
(Test) $1000 stuff WER 5000pcs
$1000 stuff WER 5000pcs
500pcs $1000 stuff WER 5000pcs";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}