re = /[^\s]*\d+[^\s]* ?/m
str = '(Promotion) stuff ABC 1pcs
(Trial) $200 stuff XYZ 20pcs
(Test) $1000 stuff WER 5000pcs
$1000 stuff WER 5000pcs
500pcs $1000 stuff WER 5000pcs'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result