use strict;
my $str = '(Promotion) stuff ABC 1pcs
(Trial) $200 stuff XYZ 20pcs
(Test) $1000 stuff WER 5000pcs
$1000 stuff WER 5000pcs
500pcs $1000 stuff WER 5000pcs';
my $regex = qr/[^\s]*\d+[^\s]* ?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";