$re = '/[^\s]*\d+[^\s]* ?/m';
$str = '(Promotion) stuff ABC 1pcs
(Trial) $200 stuff XYZ 20pcs
(Test) $1000 stuff WER 5000pcs
$1000 stuff WER 5000pcs
500pcs $1000 stuff WER 5000pcs';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;