#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\d+(?:\s*,\s*\d+)*\s*$"
Local $sString = "1 , 8,9, 88" & @CRLF & _
" 8 , 44, 3 , 11" & @CRLF & _
"1,2,3,4" & @CRLF & _
"1 , 2,3,9" & @CRLF & _
" 8 , 44, 3 , 11 " & @CRLF & _
"1 " & @CRLF & _
"1,2" & @CRLF & _
" 1,2 " & @CRLF & _
"1 ,2 " & @CRLF & _
"1 2, 5" & @CRLF & _
"1, 2," & @CRLF & _
", 1,2," & @CRLF & _
"1,2 3,4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")