// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*\d+(?:\s*,\s*\d+)*\s*$").unwrap();
let string = "1 , 8,9, 88
8 , 44, 3 , 11
1,2,3,4
1 , 2,3,9
8 , 44, 3 , 11
1
1,2
1,2
1 ,2
1 2, 5
1, 2,
, 1,2,
1,2 3,4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}