import re
regex = re.compile(r"^\s*\d+(?:\s*,\s*\d+)*\s*$", flags=re.MULTILINE)
test_str = ("1 , 8,9, 88\n"
" 8 , 44, 3 , 11\n"
"1,2,3,4\n"
"1 , 2,3,9\n"
" 8 , 44, 3 , 11 \n"
"1 \n"
"1,2\n"
" 1,2 \n"
"1 ,2 \n"
"1 2, 5\n"
"1, 2,\n"
", 1,2,\n"
"1,2 3,4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")