import Foundation
let pattern = #"^\s*\d+(?:\s*,\s*\d+)*\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 , 8,9, 88
8 , 44, 3 , 11
1,2,3,4
1 , 2,3,9
8 , 44, 3 , 11
1
1,2
1,2
1 ,2
1 2, 5
1, 2,
, 1,2,
1,2 3,4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)