package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\d+(?:\s*,\s*\d+)*\s*$`)
var str = `1 , 8,9, 88
8 , 44, 3 , 11
1,2,3,4
1 , 2,3,9
8 , 44, 3 , 11
1
1,2
1,2
1 ,2
1 2, 5
1, 2,
, 1,2,
1,2 3,4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}