import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\d+(?:\\s*,\\s*\\d+)*\\s*$";
final String string = "1 , 8,9, 88\n"
+ " 8 , 44, 3 , 11\n"
+ "1,2,3,4\n"
+ "1 , 2,3,9\n"
+ " 8 , 44, 3 , 11 \n"
+ "1 \n"
+ "1,2\n"
+ " 1,2 \n"
+ "1 ,2 \n"
+ "1 2, 5\n"
+ "1, 2,\n"
+ ", 1,2,\n"
+ "1,2 3,4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}