#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<script)((?:(?!src=).)*?>)"
Local $sString = "<script>console.log("Jareté!");</script>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript">console.log('Hola!');</script> " & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript">console.log("Jaguereté!");</script>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script> "
Local $sSubst = "$1 nonce="$cspNonce"$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)