re = /(<script)((?:(?!src=).)*?>)/
str = '<script>console.log("Jareté!");</script>
<script type="text/javascript">console.log(\'Hola!\');</script>
<script type="text/javascript">console.log("Jaguereté!");</script>
<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script>
<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script> '
subst = '$1 nonce="$cspNonce"$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result