using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<script)((?:(?!src=).)*?>)";
string substitution = @"$1 nonce=""$cspNonce""$2";
string input = @"<script>console.log(""Jareté!"");</script>
<script type=""text/javascript"">console.log('Hola!');</script>
<script type=""text/javascript"">console.log(""Jaguereté!"");</script>
<script type=""text/javascript"" src=""whatever.js"">console.log(""Jaguereté!"");</script>
<script type=""text/javascript"" src=""whatever.js"">console.log(""Jaguereté!"");</script> ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}