use strict;
my $str = '<script>console.log("Jareté!");</script>
<script type="text/javascript">console.log(\'Hola!\');</script>
<script type="text/javascript">console.log("Jaguereté!");</script>
<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script>
<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script> ';
my $regex = qr/(<script)((?:(?!src=).)*?>)/p;
my $subst = '$1 nonce="$cspNonce"$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";