# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<script)((?:(?!src=).)*?>)"
test_str = ("<script>console.log(\"Jareté!\");</script>\n\n"
"<script type=\"text/javascript\">console.log('Hola!');</script> \n\n"
"<script type=\"text/javascript\">console.log(\"Jaguereté!\");</script>\n\n"
"<script type=\"text/javascript\" src=\"whatever.js\">console.log(\"Jaguereté!\");</script>\n\n"
"<script type=\"text/javascript\" src=\"whatever.js\">console.log(\"Jaguereté!\");</script> ")
subst = "$1 nonce=\"$cspNonce\"$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.