import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<script)((?:(?!src=).)*?>)";
final String string = "<script>console.log(\"Jareté!\");</script>\n\n"
+ "<script type=\"text/javascript\">console.log('Hola!');</script> \n\n"
+ "<script type=\"text/javascript\">console.log(\"Jaguereté!\");</script>\n\n"
+ "<script type=\"text/javascript\" src=\"whatever.js\">console.log(\"Jaguereté!\");</script>\n\n"
+ "<script type=\"text/javascript\" src=\"whatever.js\">console.log(\"Jaguereté!\");</script> ";
final String subst = "$1 nonce=\"$cspNonce\"$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}