$re = '/(<script)((?:(?!src=).)*?>)/';
$str = '<script>console.log("Jareté!");</script>
<script type="text/javascript">console.log(\'Hola!\');</script>
<script type="text/javascript">console.log("Jaguereté!");</script>
<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script>
<script type="text/javascript" src="whatever.js">console.log("Jaguereté!");</script> ';
$subst = "$1 nonce=\"$cspNonce\"$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;