# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Alice)\1\1\1\1(Bob)\2\2/$1$1\1\1\n$2$2\2\2\2\2/gm;t' <<< "AliceAliceAliceAliceAliceAliceBobBobBob"