#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(Alice)\1\1\1\1(Bob)\2\2"
Local $sString = "AliceAliceAliceAliceAliceAliceBobBobBob"
Local $sSubst = "$1$1\1\1\n$2$2\2\2\2\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)