import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Alice)\\1\\1\\1\\1(Bob)\\2\\2";
final String string = "AliceAliceAliceAliceAliceAliceBobBobBob";
final String subst = "$1$1\\1\\1\\n$2$2\\2\\2\\2\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}