re = /(Alice)\1\1\1\1(Bob)\2\2/m
str = 'AliceAliceAliceAliceAliceAliceBobBobBob'
subst = '$1$1\\1\\1\\n$2$2\\2\\2\\2\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result