use strict;
my $str = 'AliceAliceAliceAliceAliceAliceBobBobBob';
my $regex = qr/(Alice)\1\1\1\1(Bob)\2\2/mp;
my $subst = '$1$1\\1\\1\\n$2$2\\2\\2\\2\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";