const regex = /(Alice)\1\1\1\1(Bob)\2\2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Alice)\\1\\1\\1\\1(Bob)\\2\\2', 'gm')
const str = `AliceAliceAliceAliceAliceAliceBobBobBob`;
const subst = `$1$1\1\1\n$2$2\2\2\2\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);