import Foundation
let pattern = #"(Alice)\1\1\1\1(Bob)\2\2"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"AliceAliceAliceAliceAliceAliceBobBobBob"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$1\1\1\n$2$2\2\2\2\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)