$re = '/(Alice)\1\1\1\1(Bob)\2\2/m';
$str = 'AliceAliceAliceAliceAliceAliceBobBobBob';
$subst = "$1$1\1\1\n$2$2\2\2\2\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;