#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)node_modules\/(?!(react-native|my-project|react-native-button)\/)"
Local $sString = "/node_modules/react-native/index.js" & @CRLF & _
"/node_modules/react-nativeee/index.js" & @CRLF & _
"/node_modules/my-project/index.js" & @CRLF & _
"/node_modules/my-projector/index.js" & @CRLF & _
"/node_modules/my-project-also/index.js" & @CRLF & _
"/node_modules/react-native-button/index.js" & @CRLF & _
"/node_modules/react-native-buttonholder/index.js" & @CRLF & _
"/node_modules/react-native-button-extra/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/react-native/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/react-nativeee/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/my-project/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/my-projector/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/my-project-also/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/react-native-button/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/react-native-buttonholder/index.js" & @CRLF & _
"/foo/bar/baz/node_modules/react-native-button-extra/index.js" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")