import Foundation
let pattern = #"node_modules\/(?!(react-native|my-project|react-native-button)\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/node_modules/react-native/index.js
/node_modules/react-nativeee/index.js
/node_modules/my-project/index.js
/node_modules/my-projector/index.js
/node_modules/my-project-also/index.js
/node_modules/react-native-button/index.js
/node_modules/react-native-buttonholder/index.js
/node_modules/react-native-button-extra/index.js
/foo/bar/baz/node_modules/react-native/index.js
/foo/bar/baz/node_modules/react-nativeee/index.js
/foo/bar/baz/node_modules/my-project/index.js
/foo/bar/baz/node_modules/my-projector/index.js
/foo/bar/baz/node_modules/my-project-also/index.js
/foo/bar/baz/node_modules/react-native-button/index.js
/foo/bar/baz/node_modules/react-native-buttonholder/index.js
/foo/bar/baz/node_modules/react-native-button-extra/index.js
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)