# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"node_modules\/(?!(react-native|my-project|react-native-button)\/)"
test_str = ("/node_modules/react-native/index.js\n"
"/node_modules/react-nativeee/index.js\n"
"/node_modules/my-project/index.js\n"
"/node_modules/my-projector/index.js\n"
"/node_modules/my-project-also/index.js\n"
"/node_modules/react-native-button/index.js\n"
"/node_modules/react-native-buttonholder/index.js\n"
"/node_modules/react-native-button-extra/index.js\n"
"/foo/bar/baz/node_modules/react-native/index.js\n"
"/foo/bar/baz/node_modules/react-nativeee/index.js\n"
"/foo/bar/baz/node_modules/my-project/index.js\n"
"/foo/bar/baz/node_modules/my-projector/index.js\n"
"/foo/bar/baz/node_modules/my-project-also/index.js\n"
"/foo/bar/baz/node_modules/react-native-button/index.js\n"
"/foo/bar/baz/node_modules/react-native-buttonholder/index.js\n"
"/foo/bar/baz/node_modules/react-native-button-extra/index.js\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.