re = /node_modules\/(?!(react-native|my-project|react-native-button)\/)/m
str = '/node_modules/react-native/index.js
/node_modules/react-nativeee/index.js
/node_modules/my-project/index.js
/node_modules/my-projector/index.js
/node_modules/my-project-also/index.js
/node_modules/react-native-button/index.js
/node_modules/react-native-buttonholder/index.js
/node_modules/react-native-button-extra/index.js
/foo/bar/baz/node_modules/react-native/index.js
/foo/bar/baz/node_modules/react-nativeee/index.js
/foo/bar/baz/node_modules/my-project/index.js
/foo/bar/baz/node_modules/my-projector/index.js
/foo/bar/baz/node_modules/my-project-also/index.js
/foo/bar/baz/node_modules/react-native-button/index.js
/foo/bar/baz/node_modules/react-native-buttonholder/index.js
/foo/bar/baz/node_modules/react-native-button-extra/index.js
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end