using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node_modules\/(?!(react-native|my-project|react-native-button)\/)";
string input = @"/node_modules/react-native/index.js
/node_modules/react-nativeee/index.js
/node_modules/my-project/index.js
/node_modules/my-projector/index.js
/node_modules/my-project-also/index.js
/node_modules/react-native-button/index.js
/node_modules/react-native-buttonholder/index.js
/node_modules/react-native-button-extra/index.js
/foo/bar/baz/node_modules/react-native/index.js
/foo/bar/baz/node_modules/react-nativeee/index.js
/foo/bar/baz/node_modules/my-project/index.js
/foo/bar/baz/node_modules/my-projector/index.js
/foo/bar/baz/node_modules/my-project-also/index.js
/foo/bar/baz/node_modules/react-native-button/index.js
/foo/bar/baz/node_modules/react-native-buttonholder/index.js
/foo/bar/baz/node_modules/react-native-button-extra/index.js
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}