use strict;
my $str = '/node_modules/react-native/index.js
/node_modules/react-nativeee/index.js
/node_modules/my-project/index.js
/node_modules/my-projector/index.js
/node_modules/my-project-also/index.js
/node_modules/react-native-button/index.js
/node_modules/react-native-buttonholder/index.js
/node_modules/react-native-button-extra/index.js
/foo/bar/baz/node_modules/react-native/index.js
/foo/bar/baz/node_modules/react-nativeee/index.js
/foo/bar/baz/node_modules/my-project/index.js
/foo/bar/baz/node_modules/my-projector/index.js
/foo/bar/baz/node_modules/my-project-also/index.js
/foo/bar/baz/node_modules/react-native-button/index.js
/foo/bar/baz/node_modules/react-native-buttonholder/index.js
/foo/bar/baz/node_modules/react-native-button-extra/index.js
';
my $regex = qr/node_modules\/(?!(react-native|my-project|react-native-button)\/)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}